Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pimcore/pimcore 11.2.3, 11.1.6.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pimcore/pimcore
- Affected
- >= 11.2.0, < 11.2.3>= 11.0.0-ALPHA1, < 11.1.6.5
- Fixed in
- 11.2.3, 11.1.6.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vjwg-28gv-pm8h lists affected ranges: Packagist pimcore/pimcore >=11.2.0 =11.0.0-ALPHA1 <11.1.6.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The TineMCE Bundle uses tinymce version 6.7.3. CVEs for this version exists for <6.8.1: https://nvd.nist.gov/vuln/detail/CVE-2024-29203 https://nvd.nist.gov/vuln/detail/CVE-2024-29881 Patches The package should be updated to at least 6.8.1 to avoid XSS vulnerability. Workarounds Upgrade pimcore to release 11.2.3 or 11.1.6.5. References https://nvd.nist.gov/vuln/detail/CVE-2024-29203 https://nvd.nist.gov/vuln/detail/CVE-2024-29881
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vjwg-28gv-pm8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vjwg-28gv-pm8h Advisory: Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881 IDs: GHSA-vjwg-28gv-pm8h Record: https://patchnext.com/advisories/ghsa-vjwg-28gv-pm8h (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pimcore/pimcore 11.2.3, 11.1.6.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pimcore/pimcore: affected >= 11.2.0, < 11.2.3; >= 11.0.0-ALPHA1, < 11.1.6.5; fixed in 11.2.3, 11.1.6.5 ## Suggested inspection (read-only) - Packagist pimcore/pimcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pimcore/pimcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vjwg-28gv-pm8h (GitHub-reviewed advisory GHSA-vjwg-28gv-pm8h lists affected ranges: Packagist pimcore/pimcore >=11.2.0 =11.0.0-ALPHA1 <11.1.6.5) Commands are suggestions: review each one before running it.
Loading voting…