Skip to content

← Actionable
Critical, CVSS 9.0amended

Elliptic's private key extraction in ECDSA upon signing a malformed input (e.g. a string)

GHSA-vjh7-7g9h-fjfh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elliptic 6.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm elliptic

    Affected
    <= 6.6.0
    Fixed in
    6.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Private key can be extracted from ECDSA signature upon signing a malformed input (e.g. a string or a number), which could e.g. come from JSON network input Note that elliptic by design accepts hex strings as one of the possible input types Details In this code: https://github.com/indutny/elliptic/blob/3e46a48fdd2ef2f89593e5e058d85530578c9761/lib/elliptic/ec/index.js#L100-L107 msg is a BN instance after conversion, but nonce is an array, and different BN instances could generate equivalent arrays after conversion. Meaning that a same nonce could be generated for different messages used in signing process, leading to k reuse, leading to private key extraction from a pair of signatures Such a message can be constructed for any already known message/signature pair, meaning that the attack needs only a single malicious message being signed for a full key extraction While signing unverified attacker-controlled messages would be problematic itself (and exploitation of this needs…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vjh7-7g9h-fjfh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vjh7-7g9h-fjfh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vjh7-7g9h-fjfh

Advisory: Elliptic's private key extraction in ECDSA upon signing a malformed input (e.g. a string)
IDs: GHSA-vjh7-7g9h-fjfh
Record: https://patchnext.com/advisories/ghsa-vjh7-7g9h-fjfh (revision 3, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elliptic 6.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm elliptic: affected <= 6.6.0; fixed in 6.6.1

## Suggested inspection (read-only)
- `npm ls elliptic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elliptic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vjh7-7g9h-fjfh (OSV record GHSA-vjh7-7g9h-fjfh lists affected ranges: npm elliptic >=0 <6.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vjh7-7g9h-fjfh (GitHub-reviewed advisory GHSA-vjh7-7g9h-fjfh lists affected ranges: npm elliptic >=0 <=6.6.0)

Commands are suggestions: review each one before running it.

Loading voting…