Etcd auth Inaccurate logging of authentication attempts for users with CN-based auth only
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.etcd.io/etcd/v3 3.4.10, 3.3.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 3.4.0-rc.0, <= 3.4.9< 3.3.23
- Fixed in
- 3.3.23, 3.4.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vjg6-93fv-qv64 lists affected ranges: Go go.etcd.io/etcd/v3 >=3.4.0-rc.0 =0 <3.3.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Vulnerability type Logging Detail etcd users who have no password can authenticate only through a client certificate. When such users try to authenticate into etcd using the Authenticate endpoint, errors are logged with insufficient information regarding why the authentication failed, and may be misleading when auditing etcd logs. References Find out more on this vulnerability in the security audit report For more information If you have any questions or comments about this advisory: Contact the etcd security committee
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vjg6-93fv-qv64
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vjg6-93fv-qv64 Advisory: Etcd auth Inaccurate logging of authentication attempts for users with CN-based auth only IDs: GHSA-vjg6-93fv-qv64 Record: https://patchnext.com/advisories/ghsa-vjg6-93fv-qv64 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: go.etcd.io/etcd/v3 3.4.10, 3.3.23. A vendor fix does not mean a deployment is fixed. ## Affected components - Go go.etcd.io/etcd/v3: affected >= 3.4.0-rc.0, <= 3.4.9; < 3.3.23; fixed in 3.3.23, 3.4.10 ## Suggested inspection (read-only) - Go go.etcd.io/etcd/v3: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on go.etcd.io/etcd/v3. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vjg6-93fv-qv64 (GitHub-reviewed advisory GHSA-vjg6-93fv-qv64 lists affected ranges: Go go.etcd.io/etcd/v3 >=3.4.0-rc.0 =0 <3.3.23) Commands are suggestions: review each one before running it.
Loading voting…