Skip to content

← Actionable
Medium, CVSS 5.3amended

xrootd has path traversal in directory listing that allows access to the parent directory via trailing ".." pattern

GHSA-vj8v-p5vw-m6v5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xrootd 5.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI xrootd

    Affected
    < 5.9.2
    Fixed in
    5.9.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability in XRootD allows users to escape the exported directory scope and enumerate the contents of the parent directory by appending /.. (specifically without trailing slash) to an exported path in xrdfs ls or HTTP PROPFIND requests. This bypass ignores the all.export restriction. Affected component src/XrdXrootd/XrdXrootdXeq.cc, and more precisely the functions rpCheck() and Squash() used in doDirlist() (link), as they do not check if the path ends with ".." (without trailing slash). Then the path is passed directly to the filesystem layer. PoC Configuration - Configuration file: - Filesystem layout on the server: - Starting the server: xrootd -c /etc/xrootd/xrootd.cfg Steps to reproduce Normal behavior (access outside export is denied): Bypass via trailing ..: Also exploitable via HTTP PROPFIND: Returns HTTP 200 with full listing of the parent directory, including unexported entries (bob/, secret.txt). However, file download via this path traversal…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vj8v-p5vw-m6v5

  2. Revision 1 · created ·

    Published from osv record GHSA-vj8v-p5vw-m6v5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vj8v-p5vw-m6v5

Advisory: xrootd has path traversal in directory listing that allows access to the parent directory via trailing ".." pattern
IDs: GHSA-vj8v-p5vw-m6v5
Record: https://patchnext.com/advisories/ghsa-vj8v-p5vw-m6v5 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xrootd 5.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI xrootd: affected < 5.9.2; fixed in 5.9.2

## Suggested inspection (read-only)
- `python -m pip show xrootd`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xrootd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vj8v-p5vw-m6v5 (OSV record GHSA-vj8v-p5vw-m6v5 lists affected ranges: PyPI xrootd >=0 <5.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-vj8v-p5vw-m6v5 (GitHub-reviewed advisory GHSA-vj8v-p5vw-m6v5 lists affected ranges: PyPI xrootd >=0 <5.9.2)

Commands are suggestions: review each one before running it.

Loading voting…