Skip to content

← Actionable
Medium, CVSS 5.4

Silverstripe Missing CSRF protection in login form

GHSA-vj2j-6g3w-4662

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.3.2, 3.2.4, 3.1.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/framework

    Affected
    >= 3.1.18, < 3.1.19>= 3.2.3, < 3.2.4>= 3.3.1, < 3.3.2
    Fixed in
    3.2.4, 3.1.19, 3.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

LoginForm calls disableSecurityToken(), which causes a "shared host domain" vulnerability: http://stackoverflow.com/a/15350123.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vj2j-6g3w-4662

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vj2j-6g3w-4662

Advisory: Silverstripe Missing CSRF protection in login form
IDs: GHSA-vj2j-6g3w-4662
Record: https://patchnext.com/advisories/ghsa-vj2j-6g3w-4662 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.3.2, 3.2.4, 3.1.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 3.1.18, < 3.1.19; >= 3.2.3, < 3.2.4; >= 3.3.1, < 3.3.2; fixed in 3.2.4, 3.1.19, 3.3.2

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vj2j-6g3w-4662 (GitHub-reviewed advisory GHSA-vj2j-6g3w-4662 lists affected ranges: Packagist silverstripe/framework >=3.1.18 =3.2.3 =3.3.1 <3.3.2)

Commands are suggestions: review each one before running it.

Loading voting…