Skip to content

← Actionable
Medium, CVSS 5.3amended

BlastRADIUS also affects eduMFA

GHSA-vhmj-5q9r-mm9g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (edumfa 2.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI edumfa

    Affected
    < 2.2.0
    Fixed in
    2.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary BlastRADIUS (see blastradius.fail for details) also affects eduMFA prior version 2.2.0, because the Message-Authenticator attributes were not checked. Details Website with the vulnerability information blastradius.fail The original vulnerability has been assigned CVE-2024-3596 Case in vince: https://kb.cert.org/vuls/id/456537 PoC There is no known proof-of-concept except for the attack shown in the paper from the researchers Impact An attacker can trigger an authentication flow with a RADIUS-backed token, intercept the RADIUS packet sent by eduMFA and modify the RADIUS server's answer, which would lead eduMFA to believe that the token is valid, even though the RADIUS servers answer was a reject.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vhmj-5q9r-mm9g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vhmj-5q9r-mm9g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vhmj-5q9r-mm9g

Advisory: BlastRADIUS also affects eduMFA
IDs: GHSA-vhmj-5q9r-mm9g
Record: https://patchnext.com/advisories/ghsa-vhmj-5q9r-mm9g (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: edumfa 2.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI edumfa: affected < 2.2.0; fixed in 2.2.0

## Suggested inspection (read-only)
- `python -m pip show edumfa`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on edumfa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vhmj-5q9r-mm9g (OSV record GHSA-vhmj-5q9r-mm9g lists affected ranges: PyPI edumfa >=0 <2.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vhmj-5q9r-mm9g (GitHub-reviewed advisory GHSA-vhmj-5q9r-mm9g lists affected ranges: PyPI edumfa >=0 <2.2.0)

Commands are suggestions: review each one before running it.

Loading voting…