Skip to content

← Actionable
High, CVSS 7.5amended

Incorrect Account Used for Signing

GHSA-vg44-fw64-cpjx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (eth-ledger-bridge-keyring 0.2.1; @metamask/eth-ledger-bridge-keyring 0.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Anybody using this library to sign with a BIP44 account other than the first account may be affected. If a user is signing with the first account (i.e. the account at index 0), or with the legacy MEW/MyCrypto HD path, they are not affected. The vulnerability impacts cases where the user signs a personal message or transaction without first adding the account. This includes cases where the user has already added the account in a previous session (i.e. they added the account, reset the application, then signed something). The serialization/deserialization process does restore a previously added account, but it doesn't restore the index instructing the keyring to use that account for signing. As a result, after serializing then deserializing the keyring state, the account at index 0 is always used for signing even if it isn't the current account. Patches This has been patched (#14) in version >=0.2.1 of eth-ledger-bridge-keyring, and in version >=0.2.2 of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vg44-fw64-cpjx

  2. Revision 1 · created ·

    Published from osv record GHSA-vg44-fw64-cpjx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vg44-fw64-cpjx

Advisory: Incorrect Account Used for Signing
IDs: GHSA-vg44-fw64-cpjx
Record: https://patchnext.com/advisories/ghsa-vg44-fw64-cpjx (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: eth-ledger-bridge-keyring 0.2.1; @metamask/eth-ledger-bridge-keyring 0.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm eth-ledger-bridge-keyring: affected < 0.2.1; fixed in 0.2.1
- npm @metamask/eth-ledger-bridge-keyring: affected < 0.2.2; fixed in 0.2.2

## Suggested inspection (read-only)
- `npm ls eth-ledger-bridge-keyring --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @metamask/eth-ledger-bridge-keyring --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on eth-ledger-bridge-keyring, @metamask/eth-ledger-bridge-keyring.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vg44-fw64-cpjx (OSV record GHSA-vg44-fw64-cpjx lists affected ranges: npm eth-ledger-bridge-keyring >=0 =0 <0.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-vg44-fw64-cpjx (GitHub-reviewed advisory GHSA-vg44-fw64-cpjx lists affected ranges: npm eth-ledger-bridge-keyring >=0 =0 <0.2.2)

Commands are suggestions: review each one before running it.

Loading voting…