Symfony2 security issue when the trust proxy mode is enabled
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.1.4, 2.0.19; symfony/http-foundation 2.1.4, 2.0.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.0.0, < 2.0.19>= 2.1.0, < 2.1.4
- Fixed in
- 2.0.19, 2.1.4
Packagist symfony/http-foundation
- Affected
- >= 2.0.0, < 2.0.19>= 2.1.0, < 2.1.4
- Fixed in
- 2.0.19, 2.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfm6-r2gc-pwww lists affected ranges: Packagist symfony/http-foundation >=2.0.0 =2.1.0 =2.0.0 =2.1.0 <2.1.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
An application is vulnerable if it uses the client IP address as returned by the Request::getClientIp() method for sensitive decisions like IP based access control. To fix this security issue, the following changes have been made to all versions of Symfony2: A new Request::setTrustedProxies() method has been introduced and should be used intead of Request::trustProxyData() to enable the trust proxy mode. It takes an array of trusted proxy IP addresses as its argument: The Request::trustProxyData() method has been deprecated (when used, it automatically trusts the latest proxy in the chain -- which is the current remote address): We encourage all Symfony2 users to upgrade as soon as possible. It you don't want to upgrade to the latest version yet, you can also apply the following patches: - Patch for Symfony 2.0.19 - Patch for Symfony 2.1.4
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vfm6-r2gc-pwww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vfm6-r2gc-pwww Advisory: Symfony2 security issue when the trust proxy mode is enabled IDs: GHSA-vfm6-r2gc-pwww Record: https://patchnext.com/advisories/ghsa-vfm6-r2gc-pwww (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.1.4, 2.0.19; symfony/http-foundation 2.1.4, 2.0.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.0.0, < 2.0.19; >= 2.1.0, < 2.1.4; fixed in 2.0.19, 2.1.4 - Packagist symfony/http-foundation: affected >= 2.0.0, < 2.0.19; >= 2.1.0, < 2.1.4; fixed in 2.0.19, 2.1.4 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/http-foundation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/http-foundation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vfm6-r2gc-pwww (GitHub-reviewed advisory GHSA-vfm6-r2gc-pwww lists affected ranges: Packagist symfony/http-foundation >=2.0.0 =2.1.0 =2.0.0 =2.1.0 <2.1.4) Commands are suggestions: review each one before running it.
Loading voting…