Skip to content

← Actionable
Medium, CVSS 4.7

Formwork has a cross-site scripting (XSS) vulnerability in Site title

GHSA-vf6x-59hh-332f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getformwork/formwork 2.0.0-beta.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The site title field at /panel/options/site/allows embedding JS tags, which can be used to attack all members of the system. This is a widespread attack and can cause significant damage if there is a considerable number of users. Impact The attack is widespread, leveraging what XSS can do. This will undoubtedly impact system availability. Patches - Formwork 2.x (aa3e9c6) escapes site title from panel header navigation. Details By embedding "<!--", the source code can be rendered non-functional, significantly impacting system availability. However, the attacker would need admin privileges, making the attack more difficult to execute.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vf6x-59hh-332f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vf6x-59hh-332f

Advisory: Formwork has a cross-site scripting (XSS) vulnerability in Site title
IDs: GHSA-vf6x-59hh-332f
Record: https://patchnext.com/advisories/ghsa-vf6x-59hh-332f (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getformwork/formwork 2.0.0-beta.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getformwork/formwork: affected >= 2.0.0-beta.3, <= 2.0.0-beta.3; fixed in 2.0.0-beta.4

## Suggested inspection (read-only)
- Packagist getformwork/formwork: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getformwork/formwork.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vf6x-59hh-332f (GitHub-reviewed advisory GHSA-vf6x-59hh-332f lists affected ranges: Packagist getformwork/formwork >=2.0.0-beta.3 <=2.0.0-beta.3)

Commands are suggestions: review each one before running it.

Loading voting…