Skip to content

← Actionable
Low, CVSS 2.3

mo has a XSS via inline SVG script tags in Markdown rendering

GHSA-vccx-p757-pv6h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/k1LoW/mo 0.18.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary When rendering Markdown files containing inline SVG elements with <script tags, the embedded JavaScript is executed in the browser. This is due to rehype-raw passing raw HTML (including SVG) through to the DOM without sanitization. PoC Embedding the above in a Markdown file opened with mo causes the script to execute. Impact Arbitrary JavaScript execution in the context of the mo application when a user opens a malicious Markdown file. This could lead to data exfiltration of other opened Markdown file contents. Remediation Fixed by adding rehype-sanitize to the Markdown rendering pipeline, which strips dangerous elements such as <script while preserving safe HTML.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vccx-p757-pv6h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-vccx-p757-pv6h

Advisory: mo has a XSS via inline SVG script tags in Markdown rendering
IDs: GHSA-vccx-p757-pv6h
Record: https://patchnext.com/advisories/ghsa-vccx-p757-pv6h (revision 1, source checked 26 Oct 2026, 15:18 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/k1LoW/mo 0.18.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/k1LoW/mo: affected <= 0.18.4; fixed in 0.18.5

## Suggested inspection (read-only)
- Go github.com/k1LoW/mo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/k1LoW/mo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vccx-p757-pv6h (GitHub-reviewed advisory GHSA-vccx-p757-pv6h lists affected ranges: Go github.com/k1LoW/mo >=0 <=0.18.4)

Commands are suggestions: review each one before running it.

Loading voting…