DoS Vulnerability in TraceContextPropagator.Extract - OpenTelemetry.Api
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opentelemetry.autoinstrumentation 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet opentelemetry.autoinstrumentation
- Affected
- >= 1.10.0-beta.1, < 1.11.0
- Fixed in
- 1.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vc29-vg52-6643 lists affected ranges: NuGet opentelemetry.autoinstrumentation >=1.10.0-beta.1 <1.11.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? A vulnerability in OpenTelemetry.Api package 1.10.0 to 1.11.1 could cause a Denial of Service (DoS) when a tracestate and traceparent header is received. These versions are used in OpenTelemetry .NET Automatic Instrumentation 1.10.0-beta.1 and 1.10.0. Even if an application does not explicitly use trace context propagation, receiving these headers can still trigger high CPU usage. This issue impacts any application accessible over the web or backend services that process HTTP requests containing a tracestate header. Application may experience excessive resource consumption, leading to increased latency, degraded performance, or downtime. Patches Has the problem been patched? What versions should users upgrade to? This issue has been resolved in OpenTelemetry.Api 1.11.2 by reverting the change that introduced the problematic behavior in versions 1.10.0 to 1.11.1. OpenTelemetry .NET Automatic Instrumentation fixes it in 1.11.0…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vc29-vg52-6643
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-vc29-vg52-6643 Advisory: DoS Vulnerability in TraceContextPropagator.Extract - OpenTelemetry.Api IDs: GHSA-vc29-vg52-6643 Record: https://patchnext.com/advisories/ghsa-vc29-vg52-6643 (revision 1, source checked 26 Oct 2026, 17:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opentelemetry.autoinstrumentation 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet opentelemetry.autoinstrumentation: affected >= 1.10.0-beta.1, < 1.11.0; fixed in 1.11.0 ## Suggested inspection (read-only) - NuGet opentelemetry.autoinstrumentation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opentelemetry.autoinstrumentation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vc29-vg52-6643 (GitHub-reviewed advisory GHSA-vc29-vg52-6643 lists affected ranges: NuGet opentelemetry.autoinstrumentation >=1.10.0-beta.1 <1.11.0) Commands are suggestions: review each one before running it.
Loading voting…