Passbolt Api E-mail HTML injection
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (passbolt/passbolt_api 2.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist passbolt/passbolt_api
- Affected
- < 2.7.0
- Fixed in
- 2.7.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v86m-j5f7-ccwh lists affected ranges: Packagist passbolt/passbolt_api >=0 <2.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Passbolt sends e-mail to users to warn them about different type of events such as the creation, modification or deletion of a password. Those e-mails may contain user-specified input, such as a password’s title or description. Passbolt does not escape the user’s input properly, resulting in the user being able to inject HTML code in an e-mail. An authenticated attacker could share a password containing an img HTML tag in its description with an other user to obtain information about their mail user-agent. This vulnerability has a very low impact. Most MUA do not embed remote images to protect their users’ privacy.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v86m-j5f7-ccwh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-v86m-j5f7-ccwh Advisory: Passbolt Api E-mail HTML injection IDs: GHSA-v86m-j5f7-ccwh Record: https://patchnext.com/advisories/ghsa-v86m-j5f7-ccwh (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: passbolt/passbolt_api 2.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist passbolt/passbolt_api: affected < 2.7.0; fixed in 2.7.0 ## Suggested inspection (read-only) - Packagist passbolt/passbolt_api: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on passbolt/passbolt_api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v86m-j5f7-ccwh (GitHub-reviewed advisory GHSA-v86m-j5f7-ccwh lists affected ranges: Packagist passbolt/passbolt_api >=0 <2.7.0) Commands are suggestions: review each one before running it.
Loading voting…