Use of insecure jQuery version in OctoberCMS
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 1.0.466; october/october 1.0.466), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist october/system
- Affected
- >= 1.0.319, < 1.0.466
- Fixed in
- 1.0.466
Packagist october/october
- Affected
- >= 1.0.319, < 1.0.466
- Fixed in
- 1.0.466
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v73w-r9xg-7cr9 lists affected ranges: Packagist october/october >=1.0.319 =1.0.319 <1.0.466
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. Patches Issue has been patched in Build 466 (v1.0.466) by applying the recommended patch from @jquery. Workarounds Apply https://github.com/octobercms/october/commit/5c7ba9fbe9f2b596b2f0e3436ee06b91b97e5892 to your installation manually if unable to upgrade to Build 466. References - https://github.com/jquery/jquery/security/advisories/GHSA-gxr4-xjj5-5px2 - https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11022 - https://jquery.com/upgrade-guide/3.5/ For more information If you have any questions or comments about this advisory: Email us at octobercms@luketowers.ca & hello@octobercms.com Threat Assessment Assessed as Moderate by the @jquery team. Acknowledgements Thanks to @mrgswift for reporting the issue to the October CMS team.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v73w-r9xg-7cr9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-v73w-r9xg-7cr9 Advisory: Use of insecure jQuery version in OctoberCMS IDs: GHSA-v73w-r9xg-7cr9 Record: https://patchnext.com/advisories/ghsa-v73w-r9xg-7cr9 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: october/system 1.0.466; october/october 1.0.466. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist october/system: affected >= 1.0.319, < 1.0.466; fixed in 1.0.466 - Packagist october/october: affected >= 1.0.319, < 1.0.466; fixed in 1.0.466 ## Suggested inspection (read-only) - Packagist october/system: check the installed version with your package manager. - Packagist october/october: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on october/system, october/october. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v73w-r9xg-7cr9 (GitHub-reviewed advisory GHSA-v73w-r9xg-7cr9 lists affected ranges: Packagist october/october >=1.0.319 =1.0.319 <1.0.466) Commands are suggestions: review each one before running it.
Loading voting…