Nodemailer: Quadratic backtracking in the addressparser free-text fallback allows remote denial of service
CVE-2026-100700GHSA-v53p-9fqp-m79j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nodemailer 10.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nodemailer
- Affected
- <= 10.0.5
- Fixed in
- 10.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v53p-9fqp-m79j lists affected ranges: npm nodemailer >=0 <=10.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v53p-9fqp-m79j lists affected ranges: npm nodemailer >=0 <10.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-100700: 0.34% estimated exploitation activity in the next 30 days; percentile 27.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When addressparser finds no address by its strict reading, it falls back to pulling one out of the free text with /\s\b[^@\s]+@[^\s]+\b\s/. That pattern backtracks quadratically: [^@\s]+ is retried from every offset and rescans the run to the next @ each time. A single header value holding a long whitespace-free run with no usable @ blocks the Node.js event loop for tens of seconds. It is cheaper to exploit than GHSA-prgh-xp8r-p3m5: 273KB is enough for ~43s, where the comment-joined shape needed ~1.5MB for ~10s. Details The fallback in src/addressparser/index.ts ran the pattern as a search. [^@\s]+ crosses neither whitespace nor @, so from each start offset it scans forward to the next @ or to the end of the run and then fails, and the engine simply advances one character and repeats. Three shapes make every offset fail: - the run holds no @ at all - the only @ has nothing after it - the only @ has nothing before it A fourth reaches it with a valid address present but placed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v53p-9fqp-m79j
- Revision 2 · amended ·
Amended from osv record GHSA-v53p-9fqp-m79j
- Revision 1 · created ·
Published from ghsa record GHSA-v53p-9fqp-m79j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-100700 Advisory: Nodemailer: Quadratic backtracking in the addressparser free-text fallback allows remote denial of service IDs: CVE-2026-100700, GHSA-v53p-9fqp-m79j Record: https://patchnext.com/advisories/ghsa-v53p-9fqp-m79j (revision 3, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nodemailer 10.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nodemailer: affected <= 10.0.5; fixed in 10.0.6 ## Suggested inspection (read-only) - `npm ls nodemailer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nodemailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v53p-9fqp-m79j (GitHub-reviewed advisory GHSA-v53p-9fqp-m79j lists affected ranges: npm nodemailer >=0 <=10.0.5) - Verified: https://osv.dev/vulnerability/GHSA-v53p-9fqp-m79j (OSV record GHSA-v53p-9fqp-m79j lists affected ranges: npm nodemailer >=0 <10.0.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…