Skip to content

← Actionable
Medium, CVSS 5.4

Cross-Site Scripting in TYPO3 CMS Backend

GHSA-v4qr-8h2v-qpjx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms 8.7.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms

    Affected
    >= 8.0.0, < 8.7.5
    Fixed in
    8.7.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Failing to properly encode user input, backend forms are vulnerable to Cross-Site Scripting. A valid backend user account is needed to exploit this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v4qr-8h2v-qpjx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-v4qr-8h2v-qpjx

Advisory: Cross-Site Scripting in TYPO3 CMS Backend
IDs: GHSA-v4qr-8h2v-qpjx
Record: https://patchnext.com/advisories/ghsa-v4qr-8h2v-qpjx (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms 8.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms: affected >= 8.0.0, < 8.7.5; fixed in 8.7.5

## Suggested inspection (read-only)
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v4qr-8h2v-qpjx (GitHub-reviewed advisory GHSA-v4qr-8h2v-qpjx lists affected ranges: Packagist typo3/cms >=8.0.0 <8.7.5)

Commands are suggestions: review each one before running it.

Loading voting…