smol-toml: Denial of Service via TOML documents containing thousands of consecutive commented lines
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smol-toml 1.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm smol-toml
- Affected
- < 1.6.1
- Fixed in
- 1.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v3rj-xjv7-4jmq lists affected ranges: npm smol-toml >=0 <1.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v3rj-xjv7-4jmq lists affected ranges: npm smol-toml >=0 <1.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker can send a maliciously crafted TOML to cause the parser to crash, because of a stack overflow caused by thousands of consecutive commented lines. The library uses recursion internally while parsing to skip over commented lines, which can be exploited to crash an application that is processing arbitrary TOML documents. Proof of concept Impact Applications which parse arbitrary TOML documents may suffer availability issues if they receive malicious input. If uncaught, the crash may cause the application itself to crash. The impact is deemed minor, as the function is already likely to throw errors on invalid input. Downstream users are supposed to properly handle errors in such situations. Due to the design of most JavaScript runtimes, the uncontrolled recursion does not lead to excessive memory usage and the execution is quickly aborted. As a reminder, it is strongly advised when working with untrusted user input to expect errors to occur and to appropriately catch…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v3rj-xjv7-4jmq
- Revision 1 · created ·
Published from osv record GHSA-v3rj-xjv7-4jmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-v3rj-xjv7-4jmq Advisory: smol-toml: Denial of Service via TOML documents containing thousands of consecutive commented lines IDs: GHSA-v3rj-xjv7-4jmq Record: https://patchnext.com/advisories/ghsa-v3rj-xjv7-4jmq (revision 2, source checked 26 Oct 2026, 12:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: smol-toml 1.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm smol-toml: affected < 1.6.1; fixed in 1.6.1 ## Suggested inspection (read-only) - `npm ls smol-toml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on smol-toml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v3rj-xjv7-4jmq (OSV record GHSA-v3rj-xjv7-4jmq lists affected ranges: npm smol-toml >=0 <1.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-v3rj-xjv7-4jmq (GitHub-reviewed advisory GHSA-v3rj-xjv7-4jmq lists affected ranges: npm smol-toml >=0 <1.6.1) Commands are suggestions: review each one before running it.
Loading voting…