Skip to content

← Actionable
Unrated

ferris-says has undefined behavior when not using UTF-8

GHSA-v363-rrf2-5fmj

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io ferris-says

    Affected
    >= 0.1.2, <= 0.2.1>= 0.3.0, < 0.3.1
    Fixed in
    0.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected versions receive a &[u8] from the caller through a safe API, and pass it directly to the unsafe str::fromutf8unchecked function. The behavior of ferrissays::say is undefined if the bytes from the caller don't happen to be valid UTF-8. The flaw was corrected in [ferris-says#21] by using the safe str::fromutf8 instead, and returning an error on invalid input. However this fix has not yet been published to crates.io as a patch version for 0.2. Separately, [ferris-says#32] has introduced a different API for version 0.3 which accepts input as &str rather than &[u8], so is unaffected by this bug. [ferris-says#21]: https://github.com/rust-lang/ferris-says/pull/21 [ferris-says#32]: https://github.com/rust-lang/ferris-says/pull/32

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v363-rrf2-5fmj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-v363-rrf2-5fmj

Advisory: ferris-says has undefined behavior when not using UTF-8
IDs: GHSA-v363-rrf2-5fmj
Record: https://patchnext.com/advisories/ghsa-v363-rrf2-5fmj (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: ferris-says 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io ferris-says: affected >= 0.1.2, <= 0.2.1; >= 0.3.0, < 0.3.1; fixed in 0.3.1

## Suggested inspection (read-only)
- crates.io ferris-says: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ferris-says.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v363-rrf2-5fmj (GitHub-reviewed advisory GHSA-v363-rrf2-5fmj lists affected ranges: crates.io ferris-says >=0.1.2 =0.3.0 <0.3.1)

Commands are suggestions: review each one before running it.

Loading voting…