Skip to content

← Actionable
Critical, CVSS 10.0amended

Vibe-Trading FastAPI endpoints permit unauthenticated access, file upload, and an RCE chain

CVE-2026-114108GHSA-v2f8-6655-7grj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vibe-trading-ai 0.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-114108: 0.53% estimated exploitation activity in the next 30 days; percentile 44.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary: 5 findings — unauthenticated full-API exposure (F1, lead Critical), read-side authorization gap that persists even with APIAUTHKEY set (F2), unauthenticated file write of .py/.sh/.yaml to a server-returned path (F3), default-permissive CORS that combines with a loopback-only check to grant any browser page on whitelisted localhost ports credentialed cross-origin access (F-A4), and partial API-key disclosure via masksecret() (F-A5). --- Shared baseline (applies to all 5 findings) The shipped agent/.env.example line 112 ships

APIAUTHKEY= commented out. requireauth() at agent/apiserver.py line 303 executes if not apikey: return and returns None immediately when APIAUTHKEY is unset, so every endpoint decorated with dependencies=[Depends(requireauth)] operates as unauthenticated. The shipped Dockerfile does not contain a USER directive, so the FastAPI process runs as uid=0(root) inside the container (verified: docker exec id returns uid=0(root) gid=0(root)). The…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-v2f8-6655-7grj

  2. Revision 2 · amended ·

    Amended from osv record GHSA-v2f8-6655-7grj

  3. Revision 1 · created ·

    Published from ghsa record GHSA-v2f8-6655-7grj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114108

Advisory: Vibe-Trading FastAPI endpoints permit unauthenticated access, file upload, and an RCE chain
IDs: CVE-2026-114108, GHSA-v2f8-6655-7grj
Record: https://patchnext.com/advisories/ghsa-v2f8-6655-7grj (revision 3, source checked 26 Oct 2026, 13:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vibe-trading-ai 0.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vibe-trading-ai: affected >= 0.1.0, < 0.1.7; fixed in 0.1.7

## Suggested inspection (read-only)
- `python -m pip show vibe-trading-ai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vibe-trading-ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v2f8-6655-7grj (GitHub-reviewed advisory GHSA-v2f8-6655-7grj lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7)
- Verified: https://osv.dev/vulnerability/GHSA-v2f8-6655-7grj (OSV record GHSA-v2f8-6655-7grj lists affected ranges: PyPI vibe-trading-ai >=0.1.0 <0.1.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…