solspace/craft-freeform Exposed to Known Axios Vulnerabilities via Precompiled Assets
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (solspace/craft-freeform 5.5.9, 4.1.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist solspace/craft-freeform
- Affected
- < 4.1.22>= 5.0.0-beta.1, < 5.5.9
- Fixed in
- 4.1.22, 5.5.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rwr8-xrpw-9qf5 lists affected ranges: Packagist solspace/craft-freeform >=0 =5.0.0-beta.1 <5.5.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The latest versions of both 4.x and 5.x are using Axios versions < 1.7.5 and as such are subject to known vulnerabilities as per: https://security.snyk.io/package/npm/axios Details We've had this flagged up in a pen test, which indicates the issue stems from this script: /freeform/plugin.js. I couldn't see any reference to vulnerable axios versions in your package.json files, but noticed some precompiled files in packages/plugin so I'm assuming those are where the issue lies.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rwr8-xrpw-9qf5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-rwr8-xrpw-9qf5 Advisory: solspace/craft-freeform Exposed to Known Axios Vulnerabilities via Precompiled Assets IDs: GHSA-rwr8-xrpw-9qf5 Record: https://patchnext.com/advisories/ghsa-rwr8-xrpw-9qf5 (revision 1, source checked 26 Oct 2026, 14:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: solspace/craft-freeform 5.5.9, 4.1.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist solspace/craft-freeform: affected < 4.1.22; >= 5.0.0-beta.1, < 5.5.9; fixed in 4.1.22, 5.5.9 ## Suggested inspection (read-only) - Packagist solspace/craft-freeform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on solspace/craft-freeform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rwr8-xrpw-9qf5 (GitHub-reviewed advisory GHSA-rwr8-xrpw-9qf5 lists affected ranges: Packagist solspace/craft-freeform >=0 =5.0.0-beta.1 <5.5.9) Commands are suggestions: review each one before running it.
Loading voting…