Skip to content

← Actionable
High, CVSS 7.1

Cross-site scripting from content entered in the tags and multiselect fields

GHSA-rv3r-vqjj-8c76

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/cms 3.7.4, 3.6.6.1, 3.5.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/cms

    Affected
    >= 3.5.7, < 3.5.8.1>= 3.6.0, < 3.6.6.1>= 3.7.0, < 3.7.4
    Fixed in
    3.5.8.1, 3.6.6.1, 3.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Introduction Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim. Such vulnerabilities are critical if you might have potential attackers in your group of authenticated Panel users. They can escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible. Impact The tags and multiselect fields allow to select tags from an autocompleted list. The tags field also allows to enter new tags or edit existing tags. Kirby already handled escaping of the autocompleted tags, but unfortunately the Panel used HTML rendering for new or edited tags as well as for custom tags from the content file. This allowed attackers with Panel access to store malicious HTML code in a tag. The browser of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rv3r-vqjj-8c76

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-rv3r-vqjj-8c76

Advisory: Cross-site scripting from content entered in the tags and multiselect fields
IDs: GHSA-rv3r-vqjj-8c76
Record: https://patchnext.com/advisories/ghsa-rv3r-vqjj-8c76 (revision 1, source checked 26 Oct 2026, 13:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/cms 3.7.4, 3.6.6.1, 3.5.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/cms: affected >= 3.5.7, < 3.5.8.1; >= 3.6.0, < 3.6.6.1; >= 3.7.0, < 3.7.4; fixed in 3.5.8.1, 3.6.6.1, 3.7.4

## Suggested inspection (read-only)
- Packagist getkirby/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rv3r-vqjj-8c76 (GitHub-reviewed advisory GHSA-rv3r-vqjj-8c76 lists affected ranges: Packagist getkirby/cms >=3.5.7 =3.6.0 =3.7.0 <3.7.4)

Commands are suggestions: review each one before running it.

Loading voting…