XSS vulnerability in translations
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oro/platform 4.2.8, 4.1.17, 3.1.29), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist oro/platform
- Affected
- >= 3.1.0, < 3.1.29>= 4.1.0, < 4.1.17>= 4.2.0, < 4.2.8
- Fixed in
- 4.1.17, 4.2.8, 3.1.29
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rrgw-3hg3-9x8c lists affected ranges: Packagist oro/platform >=3.1.0 =4.1.0 =4.2.0 <4.2.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary An attacker with admin privileges and access to Translations management functionality may add JS payload to translation values via: - Translation management UI. - Translations downloaded via the Crowdin service may also contain JS strings used for XSS attacks, for a successful attack poisoned translation should be enabled, downloaded, and installed. - Translations uploaded via Upload translation file on the All Languages grid Workarounds There are no workarounds that address this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rrgw-3hg3-9x8c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-rrgw-3hg3-9x8c Advisory: XSS vulnerability in translations IDs: GHSA-rrgw-3hg3-9x8c Record: https://patchnext.com/advisories/ghsa-rrgw-3hg3-9x8c (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oro/platform 4.2.8, 4.1.17, 3.1.29. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist oro/platform: affected >= 3.1.0, < 3.1.29; >= 4.1.0, < 4.1.17; >= 4.2.0, < 4.2.8; fixed in 4.1.17, 4.2.8, 3.1.29 ## Suggested inspection (read-only) - Packagist oro/platform: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oro/platform. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rrgw-3hg3-9x8c (GitHub-reviewed advisory GHSA-rrgw-3hg3-9x8c lists affected ranges: Packagist oro/platform >=3.1.0 =4.1.0 =4.2.0 <4.2.8) Commands are suggestions: review each one before running it.
Loading voting…