Skip to content

← Actionable
Medium, CVSS 4.3amended

Ethereum ABI decoder DoS when parsing ZST

GHSA-rqr8-pxh7-cq3g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (eth-abi 4.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI eth-abi

    Affected
    < 4.2.0
    Fixed in
    4.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

With this notification I would like to inform about a DoS vector in the Ethereum ABI decoder. We have not yet found a way to exploit this with high impact, still the bug could potentially lead to a DoS in server systems. Feel free to ask about an extension of the embargo period. Trail of Bits is informing you and other vendors as a community service, and so we do not seek a bug bounty on these issues. BUG DESCRIPTION Parsers must be written in a robust way, which avoids for example unrecoverable crashes, misinterpretation, hangs, or excessive resource consumption. The recent news about the aCropalypse bug also highlights that more subtle bugs like blind spots in file formats can lead to serious implications. Sometimes the specifications are at fault and sometimes the implementations. In the case of the Ethereum ABI, I have to blame the specification more than the vulnerable implementations. The specification allows zero-sized-types (ZST), which can cause denial-of-service upon…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rqr8-pxh7-cq3g

  2. Revision 1 · created ·

    Published from osv record GHSA-rqr8-pxh7-cq3g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-rqr8-pxh7-cq3g

Advisory: Ethereum ABI decoder DoS when parsing ZST
IDs: GHSA-rqr8-pxh7-cq3g
Record: https://patchnext.com/advisories/ghsa-rqr8-pxh7-cq3g (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: eth-abi 4.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI eth-abi: affected < 4.2.0; fixed in 4.2.0

## Suggested inspection (read-only)
- `python -m pip show eth-abi`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on eth-abi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rqr8-pxh7-cq3g (OSV record GHSA-rqr8-pxh7-cq3g lists affected ranges: PyPI eth-abi >=0 <4.2.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rqr8-pxh7-cq3g (GitHub-reviewed advisory GHSA-rqr8-pxh7-cq3g lists affected ranges: PyPI eth-abi >=0 <4.2.0)

Commands are suggestions: review each one before running it.

Loading voting…