@better-auth/scim: account takeover and stale access via SCIM provider-id collision
CVE-2026-67330GHSA-rjg6-39jm-rgg4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@better-auth/scim 1.7.0-beta.10, 1.6.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.4.0-beta.27, <= 1.6.21>= 1.7.0-beta.0, <= 1.7.0-beta.9
- Fixed in
- 1.7.0-beta.10, 1.6.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjg6-39jm-rgg4 lists affected ranges: npm @better-auth/scim >=1.4.0-beta.27 =1.7.0-beta.0 <=1.7.0-beta.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rjg6-39jm-rgg4 lists affected ranges: npm @better-auth/scim >=1.4.0-beta.27 =1.7.0-beta.0 <1.7.0-beta.10 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-67330: 0.60% estimated exploitation activity in the next 30 days; percentile 48.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Am I affected? You are affected if your application registers the @better-auth/scim plugin and lets authenticated users generate SCIM tokens. The default canGenerateToken policy was affected, and custom policies were affected when they did not reject provider IDs already used by other account providers. The provider-ID collision issue additionally requires SSO, SAML, OIDC, generic OAuth, or social providers whose account rows use custom provider IDs, plus existing account rows under those IDs. The deprovisioning and email-update issues require only the SCIM plugin and a valid SCIM bearer token. Published versions from @better-auth/scim@1.4.0-beta.27 through 1.6.21 are affected. Beta versions from 1.7.0-beta.0 through 1.7.0-beta.9 are affected. Upgrade to @better-auth/scim@1.6.22 or 1.7.0-beta.10. Summary @better-auth/scim used the same logical provider ID for SCIM provider configuration and account ownership. SCIM token issuance did not reject all account-provider namespaces. An…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rjg6-39jm-rgg4
- Revision 2 · amended ·
Amended from osv record GHSA-rjg6-39jm-rgg4
- Revision 1 · created ·
Published from ghsa record GHSA-rjg6-39jm-rgg4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-67330 Advisory: @better-auth/scim: account takeover and stale access via SCIM provider-id collision IDs: CVE-2026-67330, GHSA-rjg6-39jm-rgg4 Record: https://patchnext.com/advisories/ghsa-rjg6-39jm-rgg4 (revision 3, source checked 26 Oct 2026, 12:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @better-auth/scim 1.7.0-beta.10, 1.6.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @better-auth/scim: affected >= 1.4.0-beta.27, <= 1.6.21; >= 1.7.0-beta.0, <= 1.7.0-beta.9; fixed in 1.7.0-beta.10, 1.6.22 ## Suggested inspection (read-only) - `npm ls @better-auth/scim --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @better-auth/scim. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rjg6-39jm-rgg4 (GitHub-reviewed advisory GHSA-rjg6-39jm-rgg4 lists affected ranges: npm @better-auth/scim >=1.4.0-beta.27 =1.7.0-beta.0 <=1.7.0-beta.9) - Verified: https://osv.dev/vulnerability/GHSA-rjg6-39jm-rgg4 (OSV record GHSA-rjg6-39jm-rgg4 lists affected ranges: npm @better-auth/scim >=1.4.0-beta.27 =1.7.0-beta.0 <1.7.0-beta.10 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…