Kimai leaks API Token Hash via Invoice Twig Template
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kimai/kimai 2.53.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist kimai/kimai
- Affected
- <= 2.52.0
- Fixed in
- 2.53.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rh42-6rj2-xwmc lists affected ranges: Packagist kimai/kimai >=0 <=2.52.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The Twig sandbox used for invoice templates blocks certain sensitive User methods (password, TOTP secret, etc.) via a blocklist in StrictPolicy::checkMethodAllowed(). However, getApiToken() and getPlainApiToken() are not on the blocklist. An admin who creates an invoice template can embed calls to these methods, causing the bcrypt or sodium hashed API password of any user who generates an invoice using that template to be included in the rendered output. Only relevant for OnPremise installations with template upload activated. Background Kimai allows admins (ROLEADMIN and above) with the manageinvoicetemplate permission to create Twig-based invoice templates. These templates are rendered in a sandboxed Twig environment with StrictPolicy controlling which methods and properties are accessible. StrictPolicy explicitly blocks: getApiToken() and getPlainApiToken() are not in this list and are freely callable. Vulnerable Code StrictPolicy.php — missing entries in the User method…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rh42-6rj2-xwmc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-rh42-6rj2-xwmc Advisory: Kimai leaks API Token Hash via Invoice Twig Template IDs: GHSA-rh42-6rj2-xwmc Record: https://patchnext.com/advisories/ghsa-rh42-6rj2-xwmc (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kimai/kimai 2.53.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist kimai/kimai: affected <= 2.52.0; fixed in 2.53.0 ## Suggested inspection (read-only) - Packagist kimai/kimai: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kimai/kimai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rh42-6rj2-xwmc (GitHub-reviewed advisory GHSA-rh42-6rj2-xwmc lists affected ranges: Packagist kimai/kimai >=0 <=2.52.0) Commands are suggestions: review each one before running it.
Loading voting…