Skip to content

← Actionable
High, CVSS 8.9amended

sharp: Vulnerabilities in libheif: GHSA-g89c-p67h-r497 and GHSA-2jg2-4ch7-h545

CVE-2026-114112GHSA-rgj7-g3m4-5g8c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sharp 0.35.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sharp

    Affected
    < 0.35.4
    Fixed in
    0.35.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.9 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2026-114112: 0.24% estimated exploitation activity in the next 30 days; percentile 15.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A number of vulnerabilities, two rated as "Critical" severity using CVSSv3, have been discovered and fixed in the upstream libheif dependency. These can lead to possible remote code execution (RCE) on glibc-based Linux when run under certain conditions. The attack vector for these claims to be "network" however sharp does not provide any networking features so this vulnerability is down-rated to a "High" severity using CVSSv4 but please note its Subsequent System Impact. Those processing untrusted input with versions of sharp prior to 0.35.4 are affected. Patches Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest version, currently 0.35.4, which provides libheif 1.23.2. Using a globally-installed libheif? Please ensure you are using the latest libheif 1.23.2. Workarounds Add the following to your code to prevent sharp from decoding AVIF images. Ensure you are using a node executable binary…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-rgj7-g3m4-5g8c

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GHSA-rgj7-g3m4-5g8c

  4. Revision 1 · created ·

    Published from ghsa record GHSA-rgj7-g3m4-5g8c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-114112

Advisory: sharp: Vulnerabilities in libheif: GHSA-g89c-p67h-r497 and GHSA-2jg2-4ch7-h545
IDs: CVE-2026-114112, GHSA-rgj7-g3m4-5g8c
Record: https://patchnext.com/advisories/ghsa-rgj7-g3m4-5g8c (revision 4, source checked 26 Oct 2026, 13:02 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sharp 0.35.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sharp: affected < 0.35.4; fixed in 0.35.4

## Suggested inspection (read-only)
- `npm ls sharp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sharp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rgj7-g3m4-5g8c (GitHub-reviewed advisory GHSA-rgj7-g3m4-5g8c lists affected ranges: npm sharp >=0 <0.35.4)
- Verified: https://osv.dev/vulnerability/GHSA-rgj7-g3m4-5g8c (OSV record GHSA-rgj7-g3m4-5g8c lists affected ranges: npm sharp >=0 <0.35.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…