adm-zip: Decompression-bomb protection (fix for CVE-2026-39244) can be bypassed by declaring uncompressed size as 0
CVE-2026-92000GHSA-rcw4-f5rp-g42v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (adm-zip 0.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm adm-zip
- Affected
- <= 0.6.0
- Fixed in
- 0.6.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcw4-f5rp-g42v lists affected ranges: npm adm-zip >=0 <=0.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rcw4-f5rp-g42v lists affected ranges: npm adm-zip >=0 <0.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-92000: 0.68% estimated exploitation activity in the next 30 days; percentile 52.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected package: adm-zip (npm) Affected version: 0.6.0 Summary The fix shipped for CVE-2026-39244 (methods/inflater.js) caps zlib's decompression output via maxOutputLength: expectedLength, where expectedLength is read directly from the ZIP entry's attacker-controlled "uncompressed size" header field (CENLEN/LOCLEN). This cap is only applied when expectedLength 0: If an attacker sets the declared uncompressed-size field to exactly 0, this condition is false, option becomes {}, and no output cap is passed to zlib at all. Node then falls back to zlib's own internal default limit (several GB), so a small, highly-compressible payload can still be decompressed to a very large size in memory -- the same class of resource-exhaustion issue the original CVE addressed, just triggered differently. Steps to Reproduce 1. Build a ZIP archive containing one DEFLATE-compressed entry whose real content is highly redundant (e.g. several MB of a repeated byte, achieving close to the ~1032:1…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rcw4-f5rp-g42v
- Revision 2 · amended ·
Amended from osv record GHSA-rcw4-f5rp-g42v
- Revision 1 · created ·
Published from ghsa record GHSA-rcw4-f5rp-g42v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-92000 Advisory: adm-zip: Decompression-bomb protection (fix for CVE-2026-39244) can be bypassed by declaring uncompressed size as 0 IDs: CVE-2026-92000, GHSA-rcw4-f5rp-g42v Record: https://patchnext.com/advisories/ghsa-rcw4-f5rp-g42v (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: adm-zip 0.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm adm-zip: affected <= 0.6.0; fixed in 0.6.1 ## Suggested inspection (read-only) - `npm ls adm-zip --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on adm-zip. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rcw4-f5rp-g42v (GitHub-reviewed advisory GHSA-rcw4-f5rp-g42v lists affected ranges: npm adm-zip >=0 <=0.6.0) - Verified: https://osv.dev/vulnerability/GHSA-rcw4-f5rp-g42v (OSV record GHSA-rcw4-f5rp-g42v lists affected ranges: npm adm-zip >=0 <0.6.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…