zfr authentication adapter did not verify validity of tokens
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zfr/zfr-oauth2-server-module 0.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zfr/zfr-oauth2-server-module
- Affected
- < 0.1.2
- Fixed in
- 0.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcm4-jv5g-wccm lists affected ranges: Packagist zfr/zfr-oauth2-server-module >=0 <0.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Previous to @2ca5bb1c2f11537be8f94ca6867d8d69789e744a (release 0.1.2), tokens weren't checked for validity/expiration. This potentially caused a security issue if expired tokens were not deleted after the expiration time was past, allowing anyone to still use invalidated authentication credentials.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rcm4-jv5g-wccm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-rcm4-jv5g-wccm Advisory: zfr authentication adapter did not verify validity of tokens IDs: GHSA-rcm4-jv5g-wccm Record: https://patchnext.com/advisories/ghsa-rcm4-jv5g-wccm (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zfr/zfr-oauth2-server-module 0.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zfr/zfr-oauth2-server-module: affected < 0.1.2; fixed in 0.1.2 ## Suggested inspection (read-only) - Packagist zfr/zfr-oauth2-server-module: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zfr/zfr-oauth2-server-module. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rcm4-jv5g-wccm (GitHub-reviewed advisory GHSA-rcm4-jv5g-wccm lists affected ranges: Packagist zfr/zfr-oauth2-server-module >=0 <0.1.2) Commands are suggestions: review each one before running it.
Loading voting…