Skip to content

← Actionable
Critical, CVSS 9.1amended

Identity Spoofing in libp2p-secio

GHSA-rch7-f4h5-x9rj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (libp2p-secio 0.9.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected versions of libp2p-secio does not correctly verify that the PeerId of DstPeer matches the PeerId discovered in the crypto handshake, resulting in a high severity identity spoofing vulnerability. Recommendation Update to version 0.9.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rch7-f4h5-x9rj

  2. Revision 1 · created ·

    Published from osv record GHSA-rch7-f4h5-x9rj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-rch7-f4h5-x9rj

Advisory: Identity Spoofing in libp2p-secio
IDs: GHSA-rch7-f4h5-x9rj
Record: https://patchnext.com/advisories/ghsa-rch7-f4h5-x9rj (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: libp2p-secio 0.9.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm libp2p-secio: affected < 0.9.0; fixed in 0.9.0

## Suggested inspection (read-only)
- `npm ls libp2p-secio --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on libp2p-secio.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rch7-f4h5-x9rj (OSV record GHSA-rch7-f4h5-x9rj lists affected ranges: npm libp2p-secio >=0 <0.9.0 (fixed))
- Verified: https://github.com/advisories/GHSA-rch7-f4h5-x9rj (GitHub-reviewed advisory GHSA-rch7-f4h5-x9rj lists affected ranges: npm libp2p-secio >=0 <0.9.0)

Commands are suggestions: review each one before running it.

Loading voting…