Skip to content

← Actionable
Critical, CVSS 10.0amended

Prototype Pollution in ali-security/mongoose

GHSA-rc4v-99cr-pjcm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@seal-security/mongoose-fixed 5.3.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability causes a Prototype Pollution in document.js, through functions such as findByIdAndUpdate(). For applications using Express and EJS, this can potentially allow remote code execution. Patches The original patched version for mongoose 5.3.3 did not include a fix for CVE-2023-3696. Therefore the existing version @seal-security/mongoose-fixed version 5.3.3 is affected by this vulnerability (though it is protected from CVE-2022-2564 and CVE-2019-17426). To mitigate this issue, a @seal-security/mongoose-fixed version 5.3.4 has been deployed. Note that this version is compatible with the original mongoose version 5.3.3, not version 5.3.4 References https://security.snyk.io/vuln/SNYK-JS-MONGOOSE-5777721 https://github.com/advisories/GHSA-9m93-w8w6-76hh https://github.com/Automattic/mongoose/commit/f1efabf350522257364aa5c2cb36e441cf08f1a2

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rc4v-99cr-pjcm

  2. Revision 1 · created ·

    Published from osv record GHSA-rc4v-99cr-pjcm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-rc4v-99cr-pjcm

Advisory: Prototype Pollution in ali-security/mongoose
IDs: GHSA-rc4v-99cr-pjcm
Record: https://patchnext.com/advisories/ghsa-rc4v-99cr-pjcm (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @seal-security/mongoose-fixed 5.3.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @seal-security/mongoose-fixed: affected >= 5.3.3, <= 5.3.3; fixed in 5.3.4

## Suggested inspection (read-only)
- `npm ls @seal-security/mongoose-fixed --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @seal-security/mongoose-fixed.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rc4v-99cr-pjcm (OSV record GHSA-rc4v-99cr-pjcm lists affected ranges: npm @seal-security/mongoose-fixed >=5.3.3 <5.3.4 (fixed))
- Verified: https://github.com/advisories/GHSA-rc4v-99cr-pjcm (GitHub-reviewed advisory GHSA-rc4v-99cr-pjcm lists affected ranges: npm @seal-security/mongoose-fixed >=5.3.3 <=5.3.3)

Commands are suggestions: review each one before running it.

Loading voting…