Skip to content

← Actionable
High, CVSS 8.2amended

pypqc private key retrieval vulnerability

GHSA-rc4p-p3j9-6577

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pypqc 0.0.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI pypqc

    Affected
    >= 0.0.4, < 0.0.6.1
    Fixed in
    0.0.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact kyber512, kyber768, and kyber1024 only: An attacker able to submit many decapsulation requests against a single private key, and to gain timing information about the decapsulation, could recover the private key. Proof-of-concept exploit exists for a local attacker. CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N/E:P/RL:O/RC:C Patches Version 0.0.6.1 and newer of PyPQC is patched. Workarounds No workarounds have been reported. The 0.0.6 - 0.0.6.1 upgrade should be a drop-in replacement; it has no known breaking changes. References Timeline 1. Cryspen researchers privately reported KyberSlash to the reference implementation maintainers. 2. Peter Schwabe partially patched KyberSlash \(only "KyberSlash 1"\) in the reference implementation on December 1st, 2023, but did not document or advertise this as a security patch. https://www.github.com/pq-crystals/kyber/commit/dda29cc63af721981ee2c831cf00822e69be3220 3. Daniel J. Bernstein publicly reported KyberSlash as a security issue on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rc4p-p3j9-6577

  2. Revision 1 · created ·

    Published from osv record GHSA-rc4p-p3j9-6577

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-rc4p-p3j9-6577

Advisory: pypqc private key retrieval vulnerability
IDs: GHSA-rc4p-p3j9-6577
Record: https://patchnext.com/advisories/ghsa-rc4p-p3j9-6577 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pypqc 0.0.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pypqc: affected >= 0.0.4, < 0.0.6.1; fixed in 0.0.6.1

## Suggested inspection (read-only)
- `python -m pip show pypqc`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pypqc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rc4p-p3j9-6577 (OSV record GHSA-rc4p-p3j9-6577 lists affected ranges: PyPI pypqc >=0.0.4 <0.0.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-rc4p-p3j9-6577 (GitHub-reviewed advisory GHSA-rc4p-p3j9-6577 lists affected ranges: PyPI pypqc >=0.0.4 <0.0.6.1)

Commands are suggestions: review each one before running it.

Loading voting…