silverstripe/framework's Member.Name is not escaped
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.4.1, 3.3.3, 3.2.5, 3.1.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist silverstripe/framework
- Affected
- >= 3.1.9-rc1, < 3.1.20>= 3.2.4-rc1, < 3.2.5>= 3.3.2-rc1, < 3.3.3>= 3.4.0-rc1, < 3.4.1
- Fixed in
- 3.1.20, 3.3.3, 3.2.5, 3.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r9vp-fp72-xgf7 lists affected ranges: Packagist silverstripe/framework >=3.1.9-rc1 =3.2.4-rc1 =3.3.2-rc1 =3.4.0-rc1 <3.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The core template framework/templates/Includes/GridFieldprint.ss uses "Printed by $Member.Name". If the currently logged in members first name or surname contain XSS, this prints the raw HTML out, because Member-getName() just returns the raw FirstName + Surname as a string, which is injected directly.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r9vp-fp72-xgf7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-r9vp-fp72-xgf7 Advisory: silverstripe/framework's `Member.Name` is not escaped IDs: GHSA-r9vp-fp72-xgf7 Record: https://patchnext.com/advisories/ghsa-r9vp-fp72-xgf7 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.4.1, 3.3.3, 3.2.5, 3.1.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist silverstripe/framework: affected >= 3.1.9-rc1, < 3.1.20; >= 3.2.4-rc1, < 3.2.5; >= 3.3.2-rc1, < 3.3.3; >= 3.4.0-rc1, < 3.4.1; fixed in 3.1.20, 3.3.3, 3.2.5, 3.4.1 ## Suggested inspection (read-only) - Packagist silverstripe/framework: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on silverstripe/framework. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r9vp-fp72-xgf7 (GitHub-reviewed advisory GHSA-r9vp-fp72-xgf7 lists affected ranges: Packagist silverstripe/framework >=3.1.9-rc1 =3.2.4-rc1 =3.3.2-rc1 =3.4.0-rc1 <3.4.1) Commands are suggestions: review each one before running it.
Loading voting…