Skip to content

← Actionable
Medium, CVSS 6.1

silverstripe/framework has Cross-site Scripting vulnerability in CMSSecurity BackURL

GHSA-r85g-7jpv-8xrx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/framework 3.4.2, 3.3.4, 3.2.6, 3.1.21), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/framework

    Affected
    >= 3.1.0-rc1, < 3.1.21>= 3.2.0-rc1, < 3.2.6>= 3.3.0-rc1, < 3.3.4>= 3.4.0-rc1, < 3.4.2
    Fixed in
    3.1.21, 3.4.2, 3.3.4, 3.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

In follow up to SS-2016-001 there is yet a minor unresolved fix to incorrectly encoded URL.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r85g-7jpv-8xrx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-r85g-7jpv-8xrx

Advisory: silverstripe/framework has Cross-site Scripting vulnerability in CMSSecurity BackURL
IDs: GHSA-r85g-7jpv-8xrx
Record: https://patchnext.com/advisories/ghsa-r85g-7jpv-8xrx (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/framework 3.4.2, 3.3.4, 3.2.6, 3.1.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/framework: affected >= 3.1.0-rc1, < 3.1.21; >= 3.2.0-rc1, < 3.2.6; >= 3.3.0-rc1, < 3.3.4; >= 3.4.0-rc1, < 3.4.2; fixed in 3.1.21, 3.4.2, 3.3.4, 3.2.6

## Suggested inspection (read-only)
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r85g-7jpv-8xrx (GitHub-reviewed advisory GHSA-r85g-7jpv-8xrx lists affected ranges: Packagist silverstripe/framework >=3.1.0-rc1 =3.2.0-rc1 =3.3.0-rc1 =3.4.0-rc1 <3.4.2)

Commands are suggestions: review each one before running it.

Loading voting…