Python-TUF vulnerable to incorrect threshold signature computation for new root metadata
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tuf 0.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tuf
- Affected
- >= 0.14.0, <= 0.15.0
- Fixed in
- 0.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r7vq-6425-j94w lists affected ranges: PyPI tuf >=0.14.0 <0.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r7vq-6425-j94w lists affected ranges: PyPI tuf >=0.14.0 <=0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact The function verifyrootselfsigned(), introduced in v0.14.0, and which verifies self-signatures in a new root metadata file, counted multiple signatures by any new root key towards the new threshold. That is, any single new root key could theoretically provide enough signatures to meet the threshold for new key self-signatures required during root metadata update. A scenario where this attack could be relevant is amazingly unlikely in practice to the point where labeling this issue as a security advisory is potentially overstating the impact of the issue. Given that new root keys only become trusted by the client after a successful root metadata update, which also requires the quorum of signatures from old trusted root keys, this issue has been evaluated as low in severity. In particular, in order to exploit this vulnerability, an attacker must: 1. Control one new root key. 2. Craft a new root metadata file such that there is a number of signatures by this new root key greater…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r7vq-6425-j94w
- Revision 1 · created ·
Published from osv record GHSA-r7vq-6425-j94w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-r7vq-6425-j94w Advisory: Python-TUF vulnerable to incorrect threshold signature computation for new root metadata IDs: GHSA-r7vq-6425-j94w Record: https://patchnext.com/advisories/ghsa-r7vq-6425-j94w (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tuf 0.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tuf: affected >= 0.14.0, <= 0.15.0; fixed in 0.16.0 ## Suggested inspection (read-only) - `python -m pip show tuf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tuf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r7vq-6425-j94w (OSV record GHSA-r7vq-6425-j94w lists affected ranges: PyPI tuf >=0.14.0 <0.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r7vq-6425-j94w (GitHub-reviewed advisory GHSA-r7vq-6425-j94w lists affected ranges: PyPI tuf >=0.14.0 <=0.15.0) Commands are suggestions: review each one before running it.
Loading voting…