Skip to content

← Actionable
High, CVSS 7.4amended

better-auth: OAuth Proxy lets an attacker sign in as another user

CVE-2026-110864GHSA-r4xp-prcw-77qf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.7.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm better-auth

    Affected
    >= 1.5.0-beta.12, < 1.7.7
    Fixed in
    1.7.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-110864: 0.29% estimated exploitation activity in the next 30 days; percentile 21.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? You may be affected if you use `better-auth` from 1.5.0-beta.12 through versions before 1.7.7 with the OAuth Proxy plugin. You are affected only if all of these are also true: - On a participating environment, the OAuth Proxy plugin has no dedicated `secret`, or its `secret` equals that environment's global Better Auth secret. - Sign-in state is stored in a cookie (`account.storeStateStrategy: "cookie"`). With a database or secondary storage, this is only the case if you chose it explicitly. - Implicit account linking is on (the default). You are not affected by this path if every participating environment uses a proxy `secret` distinct from its global Better Auth secret, if sign-in state is stored in the database, or if you use a version before 1.5.0-beta.12.

Summary The OAuth Proxy plugin trusts any user profile it can decrypt. In the affected setup, Better Auth encrypts sign-in state, including data the caller chose, with the same secret and hands it to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-r4xp-prcw-77qf

  2. Revision 1 · created ·

    Published from ghsa record GHSA-r4xp-prcw-77qf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-110864

Advisory: better-auth: OAuth Proxy lets an attacker sign in as another user
IDs: CVE-2026-110864, GHSA-r4xp-prcw-77qf
Record: https://patchnext.com/advisories/ghsa-r4xp-prcw-77qf (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.7.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected >= 1.5.0-beta.12, < 1.7.7; fixed in 1.7.7

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r4xp-prcw-77qf (GitHub-reviewed advisory GHSA-r4xp-prcw-77qf lists affected ranges: npm better-auth >=1.5.0-beta.12 <1.7.7)
- Verified: https://osv.dev/vulnerability/GHSA-r4xp-prcw-77qf (OSV record GHSA-r4xp-prcw-77qf lists affected ranges: npm better-auth >=1.5.0-beta.12 <1.7.7 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…