Angular critical CSS inlining Cross-site Scripting Vulnerability Advisory
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nguniversal/common 16.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 16.1.0, < 16.1.2
- Fixed in
- 16.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r3hf-q8q7-fv2p lists affected ranges: npm @nguniversal/common >=16.1.0 <16.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r3hf-q8q7-fv2p lists affected ranges: npm @nguniversal/common >=16.1.0 <16.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Angular Universal applications on 16.1.0 and 16.1.1 using critical CSS inlining are vulnerable to a cross-site scripting (XSS) attack where an attacker can trick another user into visiting a page which injects malicious JavaScript. Angular CLI applications without Universal do perform critical CSS inlining as well, however exploiting this requires a malicious actor to already have access to modify source code directly. Patches @nguniversal/common should be upgraded to 16.1.2 or higher. 16.2.0-rc.0 is safe. Workarounds The easiest solution is likely to upgrade Universal to 16.1.2 or downgrade to 16.0.x or lower. Alternatively you can override specifically the critters dependency with version 0.0.20 in your package.json. References Angular Blog Post
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r3hf-q8q7-fv2p
- Revision 1 · created ·
Published from osv record GHSA-r3hf-q8q7-fv2p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-r3hf-q8q7-fv2p Advisory: Angular critical CSS inlining Cross-site Scripting Vulnerability Advisory IDs: GHSA-r3hf-q8q7-fv2p Record: https://patchnext.com/advisories/ghsa-r3hf-q8q7-fv2p (revision 2, source checked 26 Oct 2026, 12:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nguniversal/common 16.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nguniversal/common: affected >= 16.1.0, < 16.1.2; fixed in 16.1.2 ## Suggested inspection (read-only) - `npm ls @nguniversal/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nguniversal/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r3hf-q8q7-fv2p (OSV record GHSA-r3hf-q8q7-fv2p lists affected ranges: npm @nguniversal/common >=16.1.0 <16.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-r3hf-q8q7-fv2p (GitHub-reviewed advisory GHSA-r3hf-q8q7-fv2p lists affected ranges: npm @nguniversal/common >=16.1.0 <16.1.2) Commands are suggestions: review each one before running it.
Loading voting…