nzo/url-encryptor-bundle Insecure default secret key and IV allowing anyone to decrypt values
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nzo/url-encryptor-bundle 5.0.1, 4.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist nzo/url-encryptor-bundle
- Affected
- >= 5.0.0, < 5.0.1>= 4.0.0, < 4.3.2
- Fixed in
- 4.3.2, 5.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r2r8-36pq-27cm lists affected ranges: Packagist nzo/url-encryptor-bundle >=5.0.0 =4.0.0 <4.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of nzo/url-encryptor-bundle prior to 5.0.1 and 4.3.2 are affected by a security vulnerability related to the lack of mandatory key and IV requirements. By default, the bundle uses the aes-256-ctr algorithm, which is susceptible to malleability attacks, potentially leading to Insecure Direct Object Reference (IDOR) vulnerabilities. Additionally, the reuse of keys enables users to decrypt and modify encrypted data if they can guess the plaintext of one ciphertext.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r2r8-36pq-27cm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-r2r8-36pq-27cm Advisory: nzo/url-encryptor-bundle Insecure default secret key and IV allowing anyone to decrypt values IDs: GHSA-r2r8-36pq-27cm Record: https://patchnext.com/advisories/ghsa-r2r8-36pq-27cm (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nzo/url-encryptor-bundle 5.0.1, 4.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist nzo/url-encryptor-bundle: affected >= 5.0.0, < 5.0.1; >= 4.0.0, < 4.3.2; fixed in 4.3.2, 5.0.1 ## Suggested inspection (read-only) - Packagist nzo/url-encryptor-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nzo/url-encryptor-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r2r8-36pq-27cm (GitHub-reviewed advisory GHSA-r2r8-36pq-27cm lists affected ranges: Packagist nzo/url-encryptor-bundle >=5.0.0 =4.0.0 <4.3.2) Commands are suggestions: review each one before running it.
Loading voting…