Skip to content

← Actionable
Medium, CVSS 5.3amended

OpenClaw has stored XSS in exported session HTML viewer via markdown/raw-HTML rendering

GHSA-r294-2894-92j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.23), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    < 2026.2.23
    Fixed in
    2026.2.23

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The exported session HTML viewer allowed stored XSS when untrusted session content included raw HTML markdown tokens or unescaped metadata fields. Impact Opening a crafted exported HTML session could execute attacker-controlled JavaScript in the viewer context. This can expose session content in the page and enable phishing or UI spoofing in the trusted export view. Affected Packages / Versions - Package: openclaw (npm) - Affected versions: <= 2026.2.22-2 - Patched version (released): = 2026.2.23 Technical Details The exporter rendered markdown with marked.parse(...) and inserted HTML via innerHTML, but did not override the html renderer token path. Raw HTML (for example <img ... onerror=...) was passed through. Additional tree/header metadata fields were interpolated without escaping in the export template. Reproduction 1. Create a session containing content like <img src=x onerror=alert(1). 2. Export the session to HTML. 3. Open the exported file. 4. Observe script…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r294-2894-92j3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r294-2894-92j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-r294-2894-92j3

Advisory: OpenClaw has stored XSS in exported session HTML viewer via markdown/raw-HTML rendering
IDs: GHSA-r294-2894-92j3
Record: https://patchnext.com/advisories/ghsa-r294-2894-92j3 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.23. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected < 2026.2.23; fixed in 2026.2.23

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r294-2894-92j3 (OSV record GHSA-r294-2894-92j3 lists affected ranges: npm openclaw >=0 <2026.2.23 (fixed))
- Verified: https://github.com/advisories/GHSA-r294-2894-92j3 (GitHub-reviewed advisory GHSA-r294-2894-92j3 lists affected ranges: npm openclaw >=0 <2026.2.23)

Commands are suggestions: review each one before running it.

Loading voting…