Skip to content

← Actionable
Low, CVSS 3.7amended

mcp-data-vis vulnerable to denial of service via unsanitized select key lookup on Object.prototype with precompile: true

GHSA-r27j-894h-3w3p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (icu-minify 4.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary icu-minify's runtime formatter resolves select branches by looking up the runtime value as a plain property on a prototype-bearing object. When the value coerces to a key that exists on Object.prototype (e.g. toString, proto, constructor, hasOwnProperty, valueOf), the lookup returns a truthy value that short-circuits the ?? options.other fallback, and the downstream iterator crashes with TypeError: nodes is not iterable. Any consumer that forwards user input into a {arg, select, …} placeholder — a common idiom for role, status, type, gender — can be crashed per-request by supplying one of those keys. In Next.js SSR (via next-intl with experimental.messages.precompile) this yields a 500 for the affected render. Details Vulnerable code paths Compilation produces a plain object whose prototype chain includes all Object.prototype members: At runtime, the formatter looks up the user-controllable value directly on that object: Because options inherits from Object.prototype, lookups…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r27j-894h-3w3p

  2. Revision 1 · created ·

    Published from osv record GHSA-r27j-894h-3w3p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-r27j-894h-3w3p

Advisory: mcp-data-vis vulnerable to denial of service via unsanitized `select` key lookup on `Object.prototype` with `precompile: true`
IDs: GHSA-r27j-894h-3w3p
Record: https://patchnext.com/advisories/ghsa-r27j-894h-3w3p (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: icu-minify 4.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm icu-minify: affected <= 4.9.1; fixed in 4.9.2

## Suggested inspection (read-only)
- `npm ls icu-minify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on icu-minify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r27j-894h-3w3p (OSV record GHSA-r27j-894h-3w3p lists affected ranges: npm icu-minify >=0 <4.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-r27j-894h-3w3p (GitHub-reviewed advisory GHSA-r27j-894h-3w3p lists affected ranges: npm icu-minify >=0 <=4.9.1)

Commands are suggestions: review each one before running it.

Loading voting…