Crawl4AI: Unauthenticated RCE via Chromium launch-argument injection in browser_config.extra_args
CVE-2026-57572GHSA-r253-r9jw-qg44
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (crawl4ai 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI crawl4ai
- Affected
- <= 0.8.9
- Fixed in
- 0.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r253-r9jw-qg44 lists affected ranges: PyPI crawl4ai >=0 <=0.8.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r253-r9jw-qg44 lists affected ranges: PyPI crawl4ai >=0 <0.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-57572: 0.94% estimated exploitation activity in the next 30 days; percentile 60.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Docker API server accepted a request-supplied browserconfig.extraargs, which flowed into Chromium's launch arguments. An attacker could inject Chromium switches that replace a child-process launch command (--utility-cmd-prefix, --renderer-cmd-prefix, --gpu-launcher, --browser-subprocess-path) together with --no-zygote, causing Chromium to fork/exec an attacker-controlled command as the container's runtime user. The Docker API is unauthenticated by default, so a single request yields arbitrary command execution. The earlier extraargs SSRF patch (0.8.9) used a denylist scoped to proxy/DNS flags; a denylist of launch switches is inherently incomplete, and these command-execution switches were not covered. Affected paths /crawl, /crawl/stream, /crawl/job accepting a request browserconfig.extraargs. Impact Unauthenticated remote code execution as the container runtime user; full read/write of application data, mounted secrets, environment, and tokens, and out-of-band…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-r253-r9jw-qg44
- Revision 2 · amended ·
Amended from osv record GHSA-r253-r9jw-qg44
- Revision 1 · created ·
Published from ghsa record GHSA-r253-r9jw-qg44
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-57572 Advisory: Crawl4AI: Unauthenticated RCE via Chromium launch-argument injection in browser_config.extra_args IDs: CVE-2026-57572, GHSA-r253-r9jw-qg44 Record: https://patchnext.com/advisories/ghsa-r253-r9jw-qg44 (revision 3, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: crawl4ai 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI crawl4ai: affected <= 0.8.9; fixed in 0.9.0 ## Suggested inspection (read-only) - `python -m pip show crawl4ai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on crawl4ai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r253-r9jw-qg44 (GitHub-reviewed advisory GHSA-r253-r9jw-qg44 lists affected ranges: PyPI crawl4ai >=0 <=0.8.9) - Verified: https://osv.dev/vulnerability/GHSA-r253-r9jw-qg44 (OSV record GHSA-r253-r9jw-qg44 lists affected ranges: PyPI crawl4ai >=0 <0.9.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…