Skip to content

← Actionable
Unrated

Improper Authentication

GHSA-qxx8-292g-2w66

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.bot.connector 4.10.3, 4.9.5, 4.8.2, 4.7.3, 4.6.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet microsoft.bot.connector

    Affected
    >= 4.6.0, < 4.6.4>= 4.7.0, < 4.7.3>= 4.8.0, < 4.8.2>= 4.9.0, < 4.9.5>= 4.10.0, < 4.10.3
    Fixed in
    4.8.2, 4.9.5, 4.10.3, 4.7.3, 4.6.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact A maliciously crafted claim may be incorrectly authenticated by the bot. Impacts bots that are not configured to be used as a Skill. This vulnerability requires an an attacker to have internal knowledge of the bot. Patches The problem has been patched in all affected versions. Please see the list of patched versions for the most appropriate one for your individual case. Workarounds Users who do not wish or are not able to upgrade can add an authentication configuration containing ClaimsValidator which throws an exception if the Claims are Skill Claims. For detailed instructions, see the link in the References section. For more information If you have any questions or comments about this advisory: Open an issue in Microsoft Bot Builder SDK Email us at bf-reports@microsoft.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qxx8-292g-2w66

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qxx8-292g-2w66

Advisory: Improper Authentication
IDs: GHSA-qxx8-292g-2w66
Record: https://patchnext.com/advisories/ghsa-qxx8-292g-2w66 (revision 1, source checked 26 Oct 2026, 16:58 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.bot.connector 4.10.3, 4.9.5, 4.8.2, 4.7.3, 4.6.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.bot.connector: affected >= 4.6.0, < 4.6.4; >= 4.7.0, < 4.7.3; >= 4.8.0, < 4.8.2; >= 4.9.0, < 4.9.5; >= 4.10.0, < 4.10.3; fixed in 4.8.2, 4.9.5, 4.10.3, 4.7.3, 4.6.4

## Suggested inspection (read-only)
- NuGet microsoft.bot.connector: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.bot.connector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxx8-292g-2w66 (GitHub-reviewed advisory GHSA-qxx8-292g-2w66 lists affected ranges: NuGet microsoft.bot.connector >=4.6.0 =4.7.0 =4.8.0 =4.9.0 =4.10.0 <4.10.3)

Commands are suggestions: review each one before running it.

Loading voting…