Skip to content

← Actionable
Critical, CVSS 9.8amended

motionEye: LFI → pass‑the‑hash admin → unsafe restore → unauth action exec (RCE)

GHSA-qxvg-h7q2-hcxh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (motioneye 0.44.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A multi‑stage chain in motionEye leads to remote code execution. The chain combines: 1. Arbitrary file read (LFI) via the picture download endpoint for local motion cameras using absolute paths. 2. Pass‑the‑hash admin auth due to accepting request signatures computed with password hashes. 3. Unsafe config restore that extracts attacker‑controlled tarballs into CONFPATH. 4. Unauthenticated action execution via /action/<id/<action. If the normal user password is unset, the chain becomes unauthenticated RCE. If a normal password exists, a normal user can still achieve admin escalation and RCE. --- Affected Code (motionEye repo) 1) LFI (absolute path) — picture/<id/download Files: - motioneye/motioneye/handlers/picture.py → download() (local motion camera branch) - motioneye/motioneye/mediafiles.py → getmediacontent() Issue: getmediacontent() only blocks .. and then joins targetdir with path. Absolute paths (e.g. /etc/hosts) bypass the join and are read directly. 2) Pass‑the‑hash…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qxvg-h7q2-hcxh

  2. Revision 2 · amended ·

    Amended from osv record GHSA-qxvg-h7q2-hcxh

  3. Revision 1 · created ·

    Published from ghsa record GHSA-qxvg-h7q2-hcxh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qxvg-h7q2-hcxh

Advisory: motionEye: LFI → pass‑the‑hash admin → unsafe restore → unauth action exec (RCE)
IDs: GHSA-qxvg-h7q2-hcxh
Record: https://patchnext.com/advisories/ghsa-qxvg-h7q2-hcxh (revision 3, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: motioneye 0.44.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI motioneye: affected < 0.44.0; fixed in 0.44.0

## Suggested inspection (read-only)
- `python -m pip show motioneye`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on motioneye.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qxvg-h7q2-hcxh (GitHub-reviewed advisory GHSA-qxvg-h7q2-hcxh lists affected ranges: PyPI motioneye >=0 <0.44.0)
- Verified: https://osv.dev/vulnerability/GHSA-qxvg-h7q2-hcxh (OSV record GHSA-qxvg-h7q2-hcxh lists affected ranges: PyPI motioneye >=0 <0.44.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…