Connect-CMS Privilege Escalation Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (opensource-workshop/connect-cms 2.3.2, 1.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist opensource-workshop/connect-cms
- Affected
- < 1.7.2>= 2.0.0, < 2.3.2
- Fixed in
- 1.7.2, 2.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qxh3-jgvh-x55j lists affected ranges: Packagist opensource-workshop/connect-cms >=0 =2.0.0 <2.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact(影響) There is a Privilege Escalation Vulnerability on the management system of Connect-CMS. Affercted Version : Connect-CMS 1.7.1, 2.3.1 and earlier Patches(修正バージョン) version 1.7.2, 2.3.1 Workarounds(運用回避手段) Upgrade Connect-CMS to latest version
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qxh3-jgvh-x55j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-qxh3-jgvh-x55j Advisory: Connect-CMS Privilege Escalation Vulnerability IDs: GHSA-qxh3-jgvh-x55j Record: https://patchnext.com/advisories/ghsa-qxh3-jgvh-x55j (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: opensource-workshop/connect-cms 2.3.2, 1.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist opensource-workshop/connect-cms: affected < 1.7.2; >= 2.0.0, < 2.3.2; fixed in 1.7.2, 2.3.2 ## Suggested inspection (read-only) - Packagist opensource-workshop/connect-cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on opensource-workshop/connect-cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qxh3-jgvh-x55j (GitHub-reviewed advisory GHSA-qxh3-jgvh-x55j lists affected ranges: Packagist opensource-workshop/connect-cms >=0 =2.0.0 <2.3.2) Commands are suggestions: review each one before running it.
Loading voting…