Skip to content

← Actionable
High, CVSS 7.1amended

React Router: RSC Mode CSRF Bypass Allows Action Execution Before 400 Response

GHSA-qwww-vcr4-c8h2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (react-router 8.3.0, 7.18.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm react-router

    Affected
    >= 7.12.0, < 7.18.2>= 8.0.0, < 8.3.0
    Fixed in
    8.3.0, 7.18.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This is a follow up to CVE-2026-22030 to address related CSRF flows in unstable RSC code paths. [!NOTE] This only affects your application if you are using the unstable RSC APIs

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qwww-vcr4-c8h2

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qwww-vcr4-c8h2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qwww-vcr4-c8h2

Advisory: React Router: RSC Mode CSRF Bypass Allows Action Execution Before 400 Response
IDs: GHSA-qwww-vcr4-c8h2
Record: https://patchnext.com/advisories/ghsa-qwww-vcr4-c8h2 (revision 3, source checked 26 Oct 2026, 13:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: react-router 8.3.0, 7.18.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm react-router: affected >= 7.12.0, < 7.18.2; >= 8.0.0, < 8.3.0; fixed in 8.3.0, 7.18.2

## Suggested inspection (read-only)
- `npm ls react-router --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on react-router.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qwww-vcr4-c8h2 (OSV record GHSA-qwww-vcr4-c8h2 lists affected ranges: npm react-router >=7.12.0 =8.0.0 <8.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qwww-vcr4-c8h2 (GitHub-reviewed advisory GHSA-qwww-vcr4-c8h2 lists affected ranges: npm react-router >=7.12.0 =8.0.0 <8.3.0)

Commands are suggestions: review each one before running it.

Loading voting…