Skip to content

← Actionable
Unrated

Data Leakage Vulnerability in livewire/livewire

GHSA-qwvp-268g-jjm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (livewire/livewire 2.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The $this-validate() method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qwvp-268g-jjm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qwvp-268g-jjm8

Advisory: Data Leakage Vulnerability in livewire/livewire
IDs: GHSA-qwvp-268g-jjm8
Record: https://patchnext.com/advisories/ghsa-qwvp-268g-jjm8 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: livewire/livewire 2.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist livewire/livewire: affected >= 2.2.5, < 2.2.6; fixed in 2.2.6

## Suggested inspection (read-only)
- Packagist livewire/livewire: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on livewire/livewire.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qwvp-268g-jjm8 (GitHub-reviewed advisory GHSA-qwvp-268g-jjm8 lists affected ranges: Packagist livewire/livewire >=2.2.5 <2.2.6)

Commands are suggestions: review each one before running it.

Loading voting…