Skip to content

← Actionable
Medium, CVSS 6.3amended

block_buffer: panic corrupts inline buffer position

GHSA-qwgh-2vcv-g2f7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (block_buffer 0.12.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io block_buffer

    Affected
    >= 0.11.0, < 0.12.1
    Fixed in
    0.12.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A caught panic may leave the cursor position of `EagerBuffer` or `ReadBuffer` in a corrupted state; this in turn allows out-of-bounds reads/writes.

Details & PoC The following two tests fail miri: ```rust #[cfg(miri)] #[test] fn eager_digest_blocks_panic_corrupts_inline_position() { // `EagerBuffer` stores its cursor in the last byte of the internal block. // When `digest_blocks` completes a previously partial block, it overwrites // that byte with input data before invoking the caller-provided `compress` // callback. If the callback panics, safe code can catch the panic and keep // using the buffer while its cursor byte no longer satisfies the internal // `pos ::new(&[1, 2]); let _ = std::panic::catch_unwind(std::panic::AssertUnwindSafe(|| { buf.digest_blocks(&[3, 0xff], |_| panic!("simulated compression failure")); })); let _ = buf.get_pos(); } #[cfg(miri)] #[test] fn read_buffer_generator_panic_corrupts_inline_position() { // `ReadBuffer` stores its cursor in…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-qwgh-2vcv-g2f7

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-qwgh-2vcv-g2f7

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-qwgh-2vcv-g2f7

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-qwgh-2vcv-g2f7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qwgh-2vcv-g2f7

Advisory: block_buffer: panic corrupts inline buffer position
IDs: GHSA-qwgh-2vcv-g2f7
Record: https://patchnext.com/advisories/ghsa-qwgh-2vcv-g2f7 (revision 5, source checked 31 Oct 2026, 06:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: block_buffer 0.12.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io block_buffer: affected >= 0.11.0, < 0.12.1; fixed in 0.12.1

## Suggested inspection (read-only)
- crates.io block_buffer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on block_buffer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qwgh-2vcv-g2f7 (OSV record GHSA-qwgh-2vcv-g2f7 lists affected ranges: crates.io block_buffer >=0 <0.12.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qwgh-2vcv-g2f7 (GitHub-reviewed advisory GHSA-qwgh-2vcv-g2f7 lists affected ranges: crates.io block_buffer >=0 <0.12.1)
- Verified: https://github.com/advisories/GHSA-qwgh-2vcv-g2f7 (GitHub-reviewed advisory GHSA-qwgh-2vcv-g2f7 lists affected ranges: crates.io block_buffer >=0.11.0 <0.12.1)
- Verified: https://osv.dev/vulnerability/GHSA-qwgh-2vcv-g2f7 (OSV record GHSA-qwgh-2vcv-g2f7 lists affected ranges: crates.io block_buffer >=0.11.0 <0.12.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…