Skip to content

← Actionable
High, CVSS 7.5

Possible bypass of token claim validation when OAuth2 Introspection caching is enabled

GHSA-qvp4-rpmr-xwrr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ory/oathkeeper 0.38.12-beta.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact When you make a request to an endpoint that requires the scope foo using an access token granted with that foo scope, introspection will be valid and that token will be cached. The problem comes when a second requests to an endpoint that requires the scope bar is made before the cache has expired. Whether the token is granted or not to the bar scope, introspection will be valid. Patches A patch will be released with v0.38.12-beta.1. Workarounds Per default, caching is disabled for the oauth2introspection authenticator. When caching is disabled, this vulnerability does not exist. Trace The cache is checked in func (a AuthenticatorOAuth2Introspection) Authenticate(...). From tokenFromCache() it seems that it only validates the token expiration date, but ignores whether the token has or not the proper scopes. Post-Mortem The vulnerability was introduced in PR #424. During review, we failed to require appropriate test coverage by the submitter which is the primary reason that the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qvp4-rpmr-xwrr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qvp4-rpmr-xwrr

Advisory: Possible bypass of token claim validation when OAuth2 Introspection caching is enabled
IDs: GHSA-qvp4-rpmr-xwrr
Record: https://patchnext.com/advisories/ghsa-qvp4-rpmr-xwrr (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ory/oathkeeper 0.38.12-beta.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ory/oathkeeper: affected >= 0.38.0-beta.2, <= 0.38.11-beta.1; fixed in 0.38.12-beta.1

## Suggested inspection (read-only)
- Go github.com/ory/oathkeeper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ory/oathkeeper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qvp4-rpmr-xwrr (GitHub-reviewed advisory GHSA-qvp4-rpmr-xwrr lists affected ranges: Go github.com/ory/oathkeeper >=0.38.0-beta.2 <=0.38.11-beta.1)

Commands are suggestions: review each one before running it.

Loading voting…