Skip to content

← Actionable
High, CVSS 8.3

Coder's workspace agent API insecure redirect handling allowed cross-agent file read and write

GHSA-qrwj-vh9x-gw5v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/coder/coder/v2 2.34.4, 2.33.10, 2.32.9, 2.29.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/coder/coder/v2

    Affected
    >= 2.34.0, < 2.34.4>= 2.33.0, < 2.33.10>= 2.30.0, < 2.32.9>= 2.27.0, < 2.29.19
    Fixed in
    2.34.4, 2.29.19, 2.33.10, 2.32.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary agentConn.apiClient() used the default redirect behavior of http.Client while its custom transport dialed the host from the request URL as long as the port was the workspace agent HTTP API port (4). Agent tailnet IPs are deterministic from agent UUIDs, so a malicious workspace agent could return a redirect to another agent's tailnet IP and cause the control-plane client to send the follow-up workspace agent API request to the victim agent instead of the intended agent. Redirects that preserve the method and body, such as HTTP 307 and 308, allow replay of write and process-start requests. HTTP 301, 302 and 303 redirects only convert POST requests to GET requests, so they are sufficient to demonstrate redirected reads but not write or command-execution primitives. Impact An authenticated user with a running workspace and control of a modified workspace agent can redirect workspace agent API requests made to their agent toward another online workspace agent reachable on the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qrwj-vh9x-gw5v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qrwj-vh9x-gw5v

Advisory: Coder's workspace agent API insecure redirect handling allowed cross-agent file read and write
IDs: GHSA-qrwj-vh9x-gw5v
Record: https://patchnext.com/advisories/ghsa-qrwj-vh9x-gw5v (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/coder/coder/v2 2.34.4, 2.33.10, 2.32.9, 2.29.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/coder/coder/v2: affected >= 2.34.0, < 2.34.4; >= 2.33.0, < 2.33.10; >= 2.30.0, < 2.32.9; >= 2.27.0, < 2.29.19; fixed in 2.34.4, 2.29.19, 2.33.10, 2.32.9

## Suggested inspection (read-only)
- Go github.com/coder/coder/v2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/coder/coder/v2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qrwj-vh9x-gw5v (GitHub-reviewed advisory GHSA-qrwj-vh9x-gw5v lists affected ranges: Go github.com/coder/coder/v2 >=2.34.0 =2.33.0 =2.30.0 =2.27.0 <2.29.19)

Commands are suggestions: review each one before running it.

Loading voting…