Skip to content

← Actionable
Low, CVSS 3.0

OCI Manifest Type Confusion Issue

GHSA-qq97-vm5h-rrhg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/distribution 2.8.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.0 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Systems that rely on digest equivalence for image attestations may be vulnerable to type confusion. Patches Upgrade to at least v2.8.0-beta.1 if you are running v2.x release. If you use the code from the main branch, update at least to the commit after b59a6f827947f9e0e67df0cfb571046de4733586. Workarounds There is no way to work around this issue without patching. References Due to an oversight in the OCI Image Specification that removed the embedded mediaType field from manifests, a maliciously crafted OCI Container Image can cause registry clients to parse the same image in two different ways without modifying the image’s digest by modifying the Content-Type header returned by a registry. This can invalidate a common pattern of relying on container image digests for equivalence. For more information If you have any questions or comments about this advisory: Open an issue in distribution Open an issue in distribution-spec Email us at cncf-distribution-security@lists.cncf.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qq97-vm5h-rrhg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qq97-vm5h-rrhg

Advisory: OCI Manifest Type Confusion Issue
IDs: GHSA-qq97-vm5h-rrhg
Record: https://patchnext.com/advisories/ghsa-qq97-vm5h-rrhg (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/distribution 2.8.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/distribution: affected < 2.8.0; fixed in 2.8.0

## Suggested inspection (read-only)
- Go github.com/docker/distribution: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/distribution.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qq97-vm5h-rrhg (GitHub-reviewed advisory GHSA-qq97-vm5h-rrhg lists affected ranges: Go github.com/docker/distribution >=0 <2.8.0)

Commands are suggestions: review each one before running it.

Loading voting…