Skip to content

← Actionable
High, CVSS 7.1amended

eduMFA: Incorrect InnoDB snapshot isolation possibly allows token reusage

GHSA-qq2p-4282-cfc5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (edumfa 2.9.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI edumfa

    Affected
    < 2.9.1
    Fixed in
    2.9.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:P/VC:H/VI:L/VA:L/SC:H/SI:L/SA:L · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact For deployments using MySQL or MariaDB < 11.6.2 (or newer with innodbsnapshotisolation=off) reusage of token values might be possible due to faulty transaction isolation inside the database. Exploiting this requires racing this transaction. Affected are all tokentypes whose values are only supposed to be used once, for example TOTP, HOTP and likely also WebAuthN. Affected Combinations: - MySQL (any version) - MariaDB with innodbsnapshotisolation=OFF - innodbsnapshotisolation was introduced in: MariaDB 10.6.18, MariaDB 10.11.8, MariaDB 11.0.6, MariaDB 11.1.5, MariaDB 11.2.4, MariaDB 11.4.2 with default OFF, can be turned ON as a workaround - for MariaDB = 11.6.2 the default is ON, which is not affected - Same rules applies for Galera with underlying MariaDB Patches Fixed in version 2.9.1 by locking rows prior to write with SELECT FOR UPDATE. Workarounds Set innodbsnapshotisolation to ON (default in MariaDB = 11.6.2, e.g packaged in Debian 13). Resources…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-qq2p-4282-cfc5

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-qq2p-4282-cfc5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qq2p-4282-cfc5

Advisory: eduMFA: Incorrect InnoDB snapshot isolation possibly allows token reusage
IDs: GHSA-qq2p-4282-cfc5
Record: https://patchnext.com/advisories/ghsa-qq2p-4282-cfc5 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: edumfa 2.9.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI edumfa: affected < 2.9.1; fixed in 2.9.1

## Suggested inspection (read-only)
- `python -m pip show edumfa`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on edumfa.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qq2p-4282-cfc5 (OSV record GHSA-qq2p-4282-cfc5 lists affected ranges: PyPI edumfa >=0 <2.9.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qq2p-4282-cfc5 (GitHub-reviewed advisory GHSA-qq2p-4282-cfc5 lists affected ranges: PyPI edumfa >=0 <2.9.1)

Commands are suggestions: review each one before running it.

Loading voting…