Skip to content

← Actionable
Medium, CVSS 4.0amended

tuf has platform-dependent delegation path matching

GHSA-qp9x-wp8f-qgjj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tuf 7.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI tuf

    Affected
    <= 6.0.0
    Fixed in
    7.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.0 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

DelegatedRole.istargetinpathpattern uses fnmatch.fnmatch to decide whether a given target path is authorized by a delegation's glob pattern. Python's fnmatch.fnmatch calls os.path.normcase() on both arguments before matching. On POSIX hosts normcase is the identity function; on Windows hosts os.path resolves to ntpath, whose normcase lowercases its input and replaces / with \. As a result, python-tuf's delegation path pattern matching is case-sensitive on Linux/macOS but case-INSENSITIVE on Windows. This makes the authorization decision for a target dependent on the host operating system of the client running the updater. The result on Windows is a TUF specification violation in the python-tuf ngclient implementation. Vulnerable code tuf/api/payload.py (HEAD 7ecb67d): fnmatch.fnmatch source (Python 3.12, unchanged in current mainline): Fix Replace fnmatch.fnmatch with fnmatch.fnmatchcase, which is explicitly documented as "not applying case normalization", so it behaves identically…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qp9x-wp8f-qgjj

  2. Revision 1 · created ·

    Published from osv record GHSA-qp9x-wp8f-qgjj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qp9x-wp8f-qgjj

Advisory: tuf has platform-dependent delegation path matching
IDs: GHSA-qp9x-wp8f-qgjj
Record: https://patchnext.com/advisories/ghsa-qp9x-wp8f-qgjj (revision 2, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tuf 7.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tuf: affected <= 6.0.0; fixed in 7.0.0

## Suggested inspection (read-only)
- `python -m pip show tuf`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tuf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qp9x-wp8f-qgjj (OSV record GHSA-qp9x-wp8f-qgjj lists affected ranges: PyPI tuf >=0 <7.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qp9x-wp8f-qgjj (GitHub-reviewed advisory GHSA-qp9x-wp8f-qgjj lists affected ranges: PyPI tuf >=0 <=6.0.0)

Commands are suggestions: review each one before running it.

Loading voting…